Hyper-V

The problem

I encountered the following situation when i was rebuilding my lab environment for my studies regarding SharePoint 2013, the disk active time on my data disk (holding the vm’s) would go up to 100% and the actual data write speed was dropping to 100KB/s where i was expecting around 60MB/s. This behaviour was shown for both Hyper-V and VMware Workstation when virtual machines were installed, or just idling after installation.

My configuration of this machine is as follows: an i7 processor, 32GB ram and a small SSD as a boot disk, and a larger SATA3 disk for storing the VHD’s. I know using an SSD for the VHD’s would be a better experience but time and financial constraints are what they are and since this is a lab environment a SATA3 disk should work fine for my purposes.

The image below shows the issue where active time is extremely high and throughput is extremely low:

xVP5i

image used from http://superuser.com/

 

I took the following steps to try and alleviate the issue, as my belief was first that it had to be some driver related issue i looked at installing the latest drivers.

  • Install latest Windows updates to the Host.
  • Install latest version of the Motherboard drivers.
  • Install latest version of the Intel INF driver package.

After these changes the issue was however not resolved, and i looked at improving my experience with changing settings on the disk and hypervisor applications.

  • Reformat the drive using the largest available allocation unit size.
  • Create single file virtual disk files in stead of multiple smaller files.

None of these options had the desired effect of easing the drive and improving read/write performance, the VM’s were constantly freezing and the disk still showed 100% active time on the host.

The solution

What did work however was the following suggestion from Dan Sewell a user on the superuser.com website:

  • Changing the Power Options settings from Balanced to High Performance.

Changing the setting, had an immediate result on the disk active time and even running multiple VM’s had no performance degradation on the disk from this point on.

You can find the link to the article and answer here: http://superuser.com/a/511481

I hope this helps you if you experience this issue.

 

 

I was trying to improve one of my VDI machines and decided it was a good idea to enable RemoteFX on the host (Windows 2008 R2 Service Pack 1) to improve the responsiveness of the VDI machine (Running Ubuntu 12.4 LTS in this case) by giving it some extra graphical oomph.

My Hyper-V lab host is also running as the Domain Controller for my lab domain, and as it turns out this combination is not able to work properly. There is no error message, nor is there a warning when you install either role on the server.

The only sign there is something wrong is the fact that the Hyper-v Manager will hang on ‘Loading Settings’ when you open the Settings for a Guest or that the machines enabeled with RemoteFX will fail to load at all.

To cut to the chase Microsoft does not offer a solution where this configuration will result in a working RemoteFX enabled machine with the Domain Controller role installed on the Host. In stead it has been declared the issue is by design and therefore not supported.

Technet article: http://support.microsoft.com/kb/2506417

You have a server that is running the Remote Desktop Virtualization Host service in Windows Server 2008 R2 Service Pack 1. When you configure Active Directory on the server to add the server as a domain controller, you experience the following symptoms:

  • All existing RemoteFX-enabled virtual machines do not start.
  • An administrator cannot create a new RemoteFX-enabled virtual machine.

I have not been able to find a way around this, several articles on the web suggest different ways to remedy the ‘Loading Settings’ issue. But all solutions end up either uninstalling or disabling the RemoteFX role or driver or moving the Domain Controller services off the machine.

Looks like i will be re-purposing some hardware to get my RemoteFX fix on.

RemoteFX whitepaper download from Microsoft: http://www.microsoft.com/en-us/download/details.aspx?id=13864

Stopping the RemoteFX VideoCap driver via command line

dism /online /disable-feature /featurename:Microsoft-Windows-RemoteFX-EmbeddedVideoCap-Setup-Package